Inbound normalized views impacted by Snowflake incident

Incident Report for Omnata

Resolved

This issue has been resolved by Snowflake via a rollback.
Posted Apr 03, 2026 - 09:30 UTC

Identified

On March 30, 2026, a Snowflake release introduced a security enhancement that changed how COPY GRANTS behaves in certain contexts. This enhancement has an unintended regression specifically affecting Native App context: when a Native App executes `CREATE OR REPLACE VIEW ... COPY GRANTS`, grants to consumer roles (such as PUBLIC) are incorrectly dropped during view recreation.

For some Omnata customers, inbound sync normalized views may be left without previously existing privileges after a sync run.

Snowflake are working on a solution to the issue, but in the meantime customers may need to manually re-add the grants after each sync run.
Posted Apr 02, 2026 - 09:07 UTC
This incident affected: Omnata Sync (Omnata Sync Engine).